ADB.exe is obsolete and has serious performance problems

I am new to android as well. dkalev's answer is correct but not very descriptive for a new user. I have outlined the steps below.

  1. Double Shift to open the search box
  2. Type SDK Manager
  3. In the results shown click "SDK Manager"
  4. In the window that opens click the second tab "SDK Tools". You should see that there is an update available for SDK Build-Tools on the first line
  5. Check "Show Package Details" in the lower right hand corner
  6. Scroll to the last item under "SDK Build-Tools" and check the box. (Mine was 28.0.1)
  7. Click "Apply"
  8. In the dialogue box that pops up, click "OK"
  9. When the installer finishes, click "Finish"
  10. Uncheck "Show Package Details" and look at "Android SDK Build-Tools" (first line). There should be no update available and it should say "Installed"
  11. Click "OK" to close the SDK Manager

That's all there is to it.

Happy coding

I had the same problem and solved it by updating the Android SDK Build-Tools. Open the SDK manager in Android studio (double shift and type SDK manager). Then on the second tab (SDK Tools) update the Android SDK Build-Tools and the error message should go away.

Sampath

17-01-2019

This works for me. Just opened Android SDK Manager Then it showed 4 Updates Available. So I just Updated it and No more above warning.

enter image description here

In my case what removed this message was (After updating everything) deleting the emulator and creating a new one. Manually updating the adb didn't solved this for. Nor updating via the Android studio Gui. In my case it seems that since the emulator was created with "old" components it keep showing the message. I had three emulators, just deleted them all and created a new one. For my surprise when it started the message was no more.

Cannot tell if performance is better or not. The message just didn't came up. Also I have everything updated to the latest (emulators and sdk).

Had the same issue but in my case the fix was slightly different, as no updates were showing for the Android SDK Tools. I opened the Virtual Device Manager and realised my emulator was running API 27. Checked back in the SDK Manager and I didn't have API 27 SDK Tools installed at all. Installing v 27 resolved the issue for me.

(You mentioned you are new to Android Studio) so I recommend pressing the Android Studio > Help > Check for updates... button that will update your environment.

First you need to check which SDK your Emulator is using and as @kuya suggested you need to follow those steps and install the latest version of that SDK Build Tool. Suppose your Emulator uses SDK 27 then you need to install latest in that series. For me it was 27.0.3. After that the error was gone.

For me, update SDK doesn't help. I solve this problem by unchecking the emulator option "Use detected ADB location". Give it a try. use detected ADB location

Try factory reset to virtual device from Android Device Manager

enter image description here